Switch startet nicht mehr und bleibt im Black-Screen

  • Guten Tag zusammen,


    Meine Switch hat bis gestern problemlos mit sxos pro und Dongle funktioniert. EmuNand und AutoRCM war eingerichtet und die aktuellste Firmware installiert.


    Ich wollte gestern eigentlich Das EmuNand auf einer weiteren SD-Karte erstellen, habe aber versehentlich eine alte SD-Karte mit altem Nand eingelegt und auf wiederherstellen geklickt. Ich habe den Fehler zwar gemerkt und abgebrochen, aber er lief noch einige Zeit nach. Danach dachte ich das es klug wäre, die Switch zurück zu setzen und die SD Karte zu formatieren. Beim Neustart wurde nochmal sxos geladen und ich habe die OFW gebootet und die Switch neu eingerichtet. Mir wurde die alte Firmware, vermutlich 5.1.0 angezeigt. Danach wurde die Switch ausgeschaltet und geht seitdem nicht mehr an. Ich vermute also mal Fuse Probleme.


    Ich kann auch kein sxos booten, neue SD-Karte einrichten hat auch nichts gebracht. Atmosphere wurde ebenfalls getestet. Ich schaffe es nicht in eine CFW zu Booten oder überhaupt ein Bild zu bekommen.



    Hat irgend jemand eine Idee was ich tun kann? Würde mich sehr freuen.



    Beste Grüße

  • muxi

    Approved the thread.
  • Danach wurde die Switch ausgeschaltet und geht seitdem nicht mehr an. Ich vermute also mal Fuse Probleme.

    Kannst du ein Problem mit dem Akku ausschließen? Eventuell ist auch nur der Akkustand am Ende gewesen, vor allem weil sich nach deiner Ausführung auch das System zuvor noch booten ließ. Selbst wenn du ein Nand Backup mit einer niedrigeren FW Version eingespielt haben solltest, würde sich eine CFW trotzdem booten lassen, weil eFuses darunter keine Rolle spielen. Du solltest einen Update Prozess auch nie unterbrechen, da dann u.U. ein Brick die Folge wäre. Ich würde nun erstmal den Akkustand kontrollieren. Dafür wäre aber das AtmoXL Paket auf deiner SD-Karte erforderlich (weil darin Hekate enthalten ist) und du müsstest über den PC mit TegraRcmGUI zu ArgonNX booten, um zu Hekate gelangen zu können, da du über den SX Dongle nur zum SX OS booten kannst. Es ist für DIESE Maßnahme auch nicht zwangsläufig das komplette AtmoXL erforderlich, aber es wäre dennoch sehr zu empfehlen (auch für die zukünftige Nutzung des SX OS) Grundsätzlich würden auch nur die Ordner argon und bootloader auf der SD-Karte dafür ausreichen.

    Die erforderlichen Schritte sind hier unter Punkt 19 beschrieben.

  • Guten Morgen muxi,


    zu aller erst, vielen Dank für deine Antwort. Die gute Nachricht ist, Die Switch bootet wieder mi SXOS, aber ich habe noch eine Frage an dich und hoffe du kannst da helfen.


    Aber kurz zu meinem Vorgehen:


    Ich habe die Switch über nacht geladen, habe TegraRcmGUI installiert, die Switch mit Jig in RCM versetzt, an den PC angeschlossen und TegraRcmGUI wollte Treiber nachinstallieren. Als das geschehen ist, hat die Switch mir angezeigt das die Boot.dat vom SXOS fehlt. Kurz ne SD-Karte mit der Boot.dat und License fertig gemacht, gestartet und AutoRCM vorsichtshalber nochmal über SXOS installiert. Danach mit Dongle neugestartet und die Switch geht wieder. Ich habe also noch gar nicht zu ArgonNX gebootet oder Hekate genutzt.


    Jetzt zu meiner Frage:

    Wie ist das "richtige" Vorgehen, um die Switch vom SXOS zu befreien, die Switch komplett relativ sauber zurück zu setzten um dann AtmoXL zu installieren? Und, macht es Sinn das Nand/emuNand nochmals jetzt zu sichern?


    Ich bin echt zufrieden mit SXOS, habe hier aber auch noch nen RCMloader Dongle liegen. Und so ziemlich jeder gibt den Rat, AtmoXL zu nutzen, aus dem Grund würde ich ganz gerne umsteigen. Ich habe aber auch gelesen das beides Parallel nutzbar ist, die entsprechende Anleitung dazu, habe ich von dir gefunden.




    Beste Grüße

  • Wie ist das "richtige" Vorgehen, um die Switch vom SXOS zu befreien, die Switch komplett relativ sauber zurück zu setzten um dann AtmoXL zu installieren? Und, macht es Sinn das Nand/emuNand nochmals jetzt zu sichern?

    Du brauchst nicht auf das SX OS zu verzichten, vor allem, da du auch eine Lizenz besitzt! Mit AtmoXL hast du neben dem SX OS und der zweiten CFW Atmosphére auch noch weitere Support Tools im Gepäck, die dir die Nutzung erleichtern. Jetzt kommt es darauf an, welche Variante des SX OS emuNand du eingerichtet hast, damit du AtmoXL effektiv nutzen kannst. Wenn du bereits einen Partition emuNand nutzen solltest, sind nur wenige Schritte zum Wechsel erforderlich. In diesem Fall solltest zunächst folgende Daten extern sichern, falls du noch NICHT das FAT32 Dateisystem auf der SD-Karte nutzt:


    Emutendo (Ordner)

    Nintendo (Ordner)

    license.dat


    Anschließend ist die SD-Karte über SAK/Guiformat nach FAT32 zu formatieren (Das ist nur erforderlich, wenn sie noch auf exFAT sein sollte).

    Dann kopierst du die Daten des AtmoXL Paketes auf die SD-Karte, sowie den emuMMC Ordner aus der Einrichtungsanleitung des AtmoXL Themas unter Punkt 1.3, sowie die oben gesicherten Daten.

    Du kannst dann auch weiterhin den TX Dongle für einen Coldboot verwenden und über die Tools "Reboot to ArgonNX" oder den "Payload Launcher" aus dem HB-Menü zu Support Payloads booten oder zu AMS. Kontrolliere auch, ob die 5 Punkte der Einrichtungsanleitung bereits umgesetzt wurden, insbesondere die Punkte 2-5 und ergänze die fehlenden Schritte noch, damit eine sichere Nutzung gewährleistet, und bei Problemen ein Plan B vorhanden ist.


    Wenn du allerdings einen Datei emuNand nutzen solltest, sind andere Schritte nötig, die ich dir gerne im AtmoXL Thema erklären kann.

    CFW AtmosphèreXL - Das Original mit zusätzlichen SigPatches und viel Zubehör


    Edit:

    habe hier aber auch noch nen RCMloader Dongle liegen

    Das wäre die bessere Alternative zum TX Dongle! Damit bist du deutlich flexibler! Du solltest diesen Dongle mit ArgonNX ausrüsten, wie es in diesem Thema unter "Hinweis zur Einrichtung des RCMLoader One für AtmoXL & amsPLUS Nutzer" beschrieben ist:

    [Anleitung] xkit RCMloader ONE Dongle optimal einrichten

  • Jetzt kommt es darauf an, welche Variante des SX OS emuNand du eingerichtet hast, damit du AtmoXL effektiv nutzen kannst. Wenn du bereits einen Partition emuNand nutzen solltest, sind nur wenige Schritte zum Wechsel erforderlich. In diesem Fall solltest zunächst folgende Daten extern sichern, falls du noch NICHT das FAT32 Dateisystem auf der SD-Karte nutzt:

    Hi muxi,


    Ich habe das emuNand wie von SXOS empfohlen als hidden Partition eingerichtet, wenn ich mich nicht irre, ist auf dem Systemspeicher aber auch eine Partition eingerichtet. Das sollte man ja nicht so einfach sichern können. Also vermutlich nochmals als Datei erstellen und diese dann extern sichern. Deshalb die Frage, ob man alles komplett zurück setzen sollte um dann sauber SXOS und AtmoXL nochmal zu installieren. Das beugt natürlich dann auch weitere Probleme vor. Die Frage wäre nur wie.


    Die SD-Karte ist natürlich im ex-Fat formatiert worden, wusste ich damals nicht besser und war ne bessere Übertragungsgeschwindigkeit. Aber das werde ich auch ändern.


    beste Grüße

  • Ich habe das emuNand wie von SXOS empfohlen als hidden Partition eingerichtet, wenn ich mich nicht irre, ist auf dem Systemspeicher aber auch eine Partition eingerichtet

    Soll das bedeuten, dass du neben dem Partition emuNand (Hidden Partition on microSD) auch einen emuNand im Systemspeicher (Files on System Storage) eingerichtet hast? Wie soll das denn funktionieren?!? Der emuNand im Systemspeicher ist absolut nicht zu empfehlen, weil er NUR Nachteile hat!! Ich lese auch, dass du AutoRCM aktiviert hast. Lies dir bitte mal diesen Artikel durch und wäge dann ab, ob du dieses Feature weiterhin nutzen möchtest. Ich rate JEDEM davon ab, AutoRCM zu nutzen!!

    RE: [Noobs] Grundlagen des Nintendo Switch-Hacking

  • Das war war mal ganz ursprünglich laut Anleitung von Executer empfohlen, was es heute schon lange nicht mehr ist. Aber wie gesagt, es kann sein das ich mich auch irre und die Partition im Speicher schon ewig nicht mehr besteht. Müsste ich nachsehen.


    muxi


    wie ich oben schon sagte, war es eine reine Vermutung. Habe eben nachgeschaut und hat sich als falsch herausgestellt. Wurde nicht auf System angelegt.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!