[Support] Umstieg von SX OS auf Atmosphére - einfache Methode

  • Nach welcher anleitung muss ich jetzt gehen?

    Du hast eine Erista v1 Konsole vorliegen. Gehe nach der Anleitung aus dem Titelpost vor. Wenn du KEINEN Emutendo Ordner im SD-Karten Root vorliegen hast, ist auch kein emuNand eingerichtet worden, was du auch daran erkennen kannst, wenn im SX OS Menü (Album) oben rechts kein "EMUNAND" unterhalb der SX OS Version steht. Durch die Umsetzung der Einrichtungsanleitung von amsPLUS wird auch der Fehler mit der nach exFAT formatierten SD-Karte korrigiert. Wenn jedoch beim Sichern des Nintendo Ordners Fehlermeldungen während des Kopiervorgangs ausgegeben werden, würde ich dir zu einer kompletten Neueinrichtung raten, weil dann korrumpierte Daten vorliegen, die der Nutzung des exFAT Dateisystems zu verschulden sind. Vorher solltest du aber deine Spielstände über JKSV sichern und für einen späteren Restore extern abspeichern!

  • Wenn ich Atmosphere istallieren möchte, muss ich meine SD Karte auf Fat32 Formatieren? Weil meine ist extFAT und da sind alle Games drauf, sonst verliere ich ja alle....

    Oder kann ich für die Istallation eine ander SD Karte nehemn und danach wieder wechseln?


    Ich habe ja jetzt SX OS mit extFAT support und alle games (nsp) auf der Karte installiert.....


    "Spielstände über JKSV sichern" Wie mache ich das?

  • Und wenn ioch Atmosphere istallieren möchte, muss ich meine SD Karte auf Fat432 Formatieren? Weil meine ist extFAT und da sind alle Games drauf, sonst verliere ich ja alle....

    Zunächst musst du erst mal schauen, ob du eine der emuNand Varianten eingerichtet hast oder auch nicht. Sollte kein Emutendo Ordner im SD-Karten Root vorliegen, hast du auch keinen emuNand eingerichtet. Wenn du deine Spiele alle installiert hast, liegen diese Daten entweder im Nand oder im Ordner "NIntendo" vor. Da du diesen vor einem Wechsel erstmal extern sichern musst, gehen dir auch diese Daten nicht verloren. Auch deine Spielstände bleiben dir erhalten, weil sie, wenn KEIN emuNand eingerichtet wäre, im Systemspeicher (sysNand) der Konsole vorliegen würden. Du darfst unter dem FAT32 Dateisystem später nur keine Dumps (insbesondere Dumps > 4GB) mehr auf die SD-Karte kopieren, um sie von dort installieren zu wollen! Diese werden von externer Quelle installiert! Schau dir dazu auch bitte mal den Punkt 7 diese Themas hier an:

    Switch CFW Startpunkt (von hier aus geht es in die richtigen Themen)


    Wenn ich jetzt meine Switch via Dongel Boote, kommt sx os ladescreen dann nintendo logo und die konsole ist aufgestartet, aber immer irgendwie in der OFW im Alnum ist das OS SX menu weg, ers kommt immer das Originale Album, was denn da los?

    Dann hast du offensichtlich in die OFW gebootet, denn bei einem gebooteten SX OS wird das Album durch das SX OS Menü ersetzt.

  • Bin jetzt wieder im CFW von SX OS gebootet :-)

    Ich habe nach gesehen, kein emunand eingerichtet.....

    Kopiere jetzt den Nintendo Ordner der SD Karte auf den PC (das Dauert :-)


    Am schluss wenn Atmosphere eingerichtet ist, den Nintendo Ordner einfach wieder auf die SD Karte (Fat32) Kopieren und alle Spiele sind wieder da?

  • Am schluss wenn Atmosphere eingerichtet ist, den Nintendo Ordner einfach wieder auf die SD Karte (Fat32) Kopieren und alle Spiele sind wieder da?

    Halte dich bitte ganz genau an die Vorgaben der amsPLUS 5 Punkte Einrichtungsanleitung und am Ende wird alles zufriedenstellend laufen!

  • Eine letzte Frage noch, was meinst du damit genau?

    "Bestücke deinen Payload-Sender (z.B. einen RCMLoader ONE) mit dem im Paket beiliegenden payload.bin Payload. Halte diese Daten / den Payload-Sender bereit, bis du später in der Anleitung zur Anwendung aufgefordert wirst. amsPLUS unterstützt auch das Booten über einen TX Dongle (SX OS Pro)"


    Ich habe nur den SX OS Pro Dongel


    Und muss ich bevor ich loslege AutoRCM auschalten im SX OS Option Menue?

  • Ich habe nur den SX OS Pro Dongel

    Dann entfällt der o.g. Schritt für dich, weil du den TX Dongle nicht mit einem Payload bestücken kannst, dieser aber dennoch unter amsPLUS verwendet werden kann!

    Und muss ich bevor ich loslege AutoRCM auschalten im SX OS Option Menue?

    Das wäre ratsam, weil dieses Feature problemverursachend und auch überflüssig ist, insbesondere dann, wenn du über die OFW Nintendo Services nutzen wolltest.

  • Dann für 1sek Power und + gedrückt, dann steht da:


    rd found..... No sd card

    press power button to reboot into RCM

    Hast du die SD-Karte nach einer der beiden, in der Anleitung genannten, Varianten auf FAT32 formatiert? Falls ja, fahre die Konsole nochmal herunter, entnehme die SD-Karte und stecke sie wieder in den Slot. Es könnte auch ein Kontaktproblem mit dem Kartenleser vorliegen.

  • Gibt es eine Möglichgkeit des die Switch wenn man Power gedrückt hält direkt in Atmosphere Bootet?


    Wenn die konsole ganz aus ist, muss mann dann immer den jig und den dongel reinstecken um sie ins Argon Menu zu Booten und danach auf die Atmosphere CFW?


    Gibt es da einen einfacheren weg um sie im CFW direkt hochzufahren wenn sie ganz aus war?


    Und müssen bneide Firmware gleich sein, also OFW und CFW?


    Bei mir ist CFW Atmosphere 12.1.0 AMS M19.5E und die OFW ist 11.0....


    Und wie kann ich die OFW Updaten ohne das nichts überschrieben wird oder danach nichts mehr geht?

  • Gibt es da einen einfacheren weg um sie im CFW direkt hochzufahren wenn sie ganz aus war?

    Das ist durch den Einbau eines TrinketM0 Modchips zu realisieren.

    Und müssen bneide Firmware gleich sein, also OFW und CFW?

    Nein, das ist egal. Du darfst nur nicht mit einer im Slot befindlichen GC in die OFW booten, wenn diese sich auf einer niedrigeren FW Version befindet, als der emuMMC. Das würde bei einer nicht passenden Lotus Chip FW zu einem Fatal Crash unter der OFW führen und dort entsprechende Error Logs hinterlassen.

    Und wie kann ich die OFW Updaten ohne das nichts überschrieben wird oder danach nichts mehr geht?

    Die OFW kann immer aktualisiert werden, da dies unabhängig vom emuMMC geschieht.

  • Moin zusammen, hallo Muxi,


    erstmal vielen Dank für deine Arbeit und Unterstützung.


    Ich versuche gerade entlang deiner Anleitung (CFW amsPLUS - Das einsteigerfreundliche All-in-One Paket (für alle Erista Revisionen)) von SX OS auf amsPLUS zu wechseln.

    Meine Switch ist eine ziemlich alte (habe die Seriennummer gecheckt und soll in jedem Fall ungepatched sein (XA4J0009...). Firmware auf sysNand ist 11.0.0, kein emuNand bisher.


    Ich habe hiermit:

    https://sx-boot-dat-creator.herokuapp.com/

    die fusee-primary.bin in eine boot.dat gewandelt und diese auf den root der SD gepackt, damit ich den SX Dongle nutzen kann.


    Ich bin in diesem Schritt deiner Anleitung:

    1.2

    Nutzer einer Erista v1 Konsole

    Nun geht es über das Booten in den RCM (Jig in die rechte Joycon Schiene schieben, Vol+ gedrückt halten und währenddessen noch zusätzlich den Powerbutton für ca. 1 Sek. drücken), sowie das Senden des ArgonNX Payloads zum ArgonNX-Auswahlmenü. Der Dongle/Payload-Sender & Jig ist nach Erscheinen des ersten amsPLUS Screens wieder zu entfernen. Aus dem ArgonNX Menü ist nun der Button Hekate per Toucheingabe anzuwählen. Folge nun den Anweisungen im Spoiler "1.2.1 Einrichtung eines Partition emuMMC".


    -> Und jetzt geht die Switch nicht an, wenn ich den Jig und SX Dongle dran habe und Vol+ und dann gleichzeitig Power drücke.


    Ich habe dann aus dem Problemlösungsteil alles gecheckt:

    Blackscreen beim initialen Booten

    • Konsole korrekt in den RCM versetzt? (Nur Erista v1 Nutzer) -> Vol+ und Power
    • Dongle Akku aufgeladen? (Nur Erista v1 Nutzer) -> hab den SX Dongle 30 Minuten laden lassen;
    • SD-Karte mit den CFW Daten im Slot? -> formatiert nach Anleitung, vorher Datenbackup gemacht und dann amsPLUS mit "angepasster" bootdat drauf
    • Korrekter Payload gesendet (wenn NICHT payload.bin des amsPLUS Paketes verwendet wurde)? (Nur Erista v1 Nutzer) -> Hier verstehe ich nicht, was ich hätte falsch machen können.
    • Akku der Switch leer? Problemlösungsversuch über Punkt 19 dieses Themas -> Die Switch bootet in die OFW ohne Probleme.

    Ich hoffe ihr / du habt eine Idee und ich bin meinem Namen nicht zu gerecht geworden.


    Vielen Dank und Gruß

    Deppp

  • Ich habe hiermit:

    https://sx-boot-dat-creator.herokuapp.com/

    die fusee-primary.bin in eine boot.dat gewandelt und diese auf den root der SD gepackt, damit ich den SX Dongle nutzen kann.

    Das ist überhaupt nicht nötig, weil amsPLUS von Haus aus das Booten von einem TX Dongle unterstützt! Lösche bitte mal alle Dateien auf der SD-Karte, die dort mit boot.* vorliegen und kopiere dann die beiden Dateien boot.dat & boot.ini aus dem amsPLUS Paket wieder hinzu! Versuche es dann erneut.

  • Das ist überhaupt nicht nötig, weil amsPLUS von Haus aus das Booten von einem TX Dongle unterstützt! Lösche bitte mal alle Dateien auf der SD-Karte, die dort mit boot.* vorliegen und kopiere dann die beiden Dateien boot.dat & boot.ini aus dem amsPLUS Paket wieder hinzu! Versuche es dann erneut.

    Klasse, jetzt geht's weiter, danke dir!


    Hallo Muxi,


    leider treffe ich auf ein weiteres Problem, dass ich auch nach vielem Lesen nicht in den Griff bekomme.

    Ich habe Schritt 1.2 beendet und bin nun bei:

    1.3 Anschließend sollte zur Sicherheit nach einem Reboot zu Atmosphére noch einmal die Systemeinstellungen aufgerufen, und dort unter der Option "Konsole" überprüft werden, ob auch hinter der AMS Versionsnummer ein "E" für EmuMMC angegeben wird! Dann kann man sich sicher sein, dass der emuMMC auch gebootet worden ist. Wäre dort stattdessen ein "S" zu sehen, wurde die CFW im sysNand gebootet. Wenn das der Fall sein sollte, wurde ein Fehler beim Vorgehen dieser Anleitung begangen. Es sollten dann die einzelnen Schritte zwecks Anwendungsfehlersuche, noch einmal durchgegangen werden.

    Ich versuche also atmosphere über amsPLUS per touch zu starten, die switch bootet, bleibt dann aber schwarz, ins OFW komme ich weiter ohne Probleme.


    Also FAQ studiert:

    2.


    amsPLUS wird nicht ordnungsgemäß gebootet / Ungewöhnliches Verhalten während des CFW Betriebs / Crashes im Zusammenhang mit Homebrew


    a) -> Ich habe kein sys-Modul oder Custom Theme installiert, bis zur Homebrew komme ich m.E. ja noch nicht

    b) -> Ich kann die SD über die Switch per PC erreichen, alle Dateien sind vorhanden (amsPLUS, Nintento, emuMMC).


    3.


    Fehlermeldung beim Booten von ArgonNX / Toucheingabe nicht möglich / Booten des emuMMC ist nicht möglich


    Möglichkeit 1

    -> Daten sind vollständig

    -> Datensicherung habe ich erledigt, aber womit kann ich dann das emuMMC Image auf Fehler prüfen, um einen Brick des emuMMC auszuschließen? Das finde ich in keiner der Punkte der FAQ, offenbar bin ich blind.


    Ich bin entsprechend noch nicht weitergegangen, habe also die sd noch nicht zurückgesetzt etc.


    Danke für deine Hilfe


    P.S. ist "nur" eine Popstar, hat bis dato aber 0 Probleme mit der Switch gemacht.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!